Niagara Falls, NY Power Disruption
Incident Report for Official Wattum Facilities
Identified
UPDATE: NED facility is offline due to a confirmed transformer failure. We expect the facility to remain offline for 1-2 weeks it will require replacing the power transformer.
Posted May 16, 2022 - 16:32 EDT
Investigating
Due to a suspected transformer failure, The Niagara Falls facility is currently offline. We are actively investigating the issue and will provide an update as soon as possible.
Posted May 10, 2022 - 18:38 EDT
This incident affects: Niagara Falls, NY - USA.